Overtone Music Network

a common space & database for harmonic overtones

Since last week youz can upgrade your Firefox version to 4.0 - if you like
to use everything here proper, please notice this list. OMN supports right now
(April 12th 2011) these following browsers:

  • Firefox 2 or 3
  • Internet Explorer 7 or 8
  • Safari 3 or 4
  • Google Chrome
Although you're welcome to use OMN with a browser that is not in this list,
some of the features on our network may not work correctly.

This content has been seen 80 times

© 2007 - 2022   Impressum - Privacy Policy - Sponsored by Yoga Vidya, Germany -   Powered by

 |  Support | Privacy  |  Terms of Service